Build tips

From FreekiWiki
Revision as of 16:15, 5 November 2005 by 192.168.3.37 (talk) (→‎Extras)
Jump to navigation Jump to search

Tips for troubleshooting and repairing common problems that we see in the build workshops.

Hard drives

GRUB GRUB GRUB GRUB

symptom: The system does not go into grub, but instead chants GRUB GRUB GRUB GRUB ad infinitum.
solution: Go into the BIOS, change the hard drive detection from auto to user, and change LBA to LARGE. Dave says this works 90% of the time, and the remaining 10% might be able to be fixed with a BIOS upgrade but - who's got the time for that? switch the hdd. we have more. --User:ideath 13:06, 12 May 2005 (PDT)

Hard drive clicks

symptom: cool noises
solution: recycle that drive!

SMART warning

if the SMART utilities say the drive is gonna die, replace it. --User:ideath 13:06, 12 May 2005 (PDT)


System not booting after baseserver install

  1. Reboot from a cloner disk
  2. Choose {boot to harddisk if grub failed to install}
  3. login as root
  4. do grub-install hd0
  5. reboot

BIOS problems

Password lock

No visible way of getting into BIOS

Hardware problems

When trying to enter BIOS, and you can't, try swapping out the IDE cables. I think this needs more detail. There are many cases when it is difficult to get into BIOS; i don't think i've seen one where the culprit was the IDE cables. -laurel

Sound

not finding sound card

symptoms: message reading "/dev/dsp can't be found"; onboard sound; IRQ 5 has nothing on it; alsaconf doesn't detect a PCI or PNP soundcard. This happened on two Dell Optiplexes.
solution: Google says they use a Crystal ISA sound card, which was an option in alsaconf. You may be able to find information about the sound chip used for your onboard sound. --User:ideath 13:06, 12 May 2005 (PDT)

won't play audio CDs

symptoms: the audio test in basiccheck plays sound, but you don't get any sound from an audio CD. KsCD ("Audio CD") recognizes the CD and looks like it's playing.
solution: make sure the cable from the sound card to the CDROM is plugged in to both; double check if there are multiple places it can plug into the sound card and look for labels that might give you clues; try a different cable if it still doesn't work. --User:ideath

"device /dev/dsp can't be opened"

symptoms: when KDE starts, an error message pops up saying "Error while initializing the sound driver: device /dev/dsp can't be opened (no such device)". Then sound no work. Wah.
solution: in a FreekBox, this is generally a problem with the sound card (often an AE Vortex PCI sound card), which should be replaced, and the offending card given to Dave so he can figure out a good fix. If you're working on a non-Freekbox/Grantbox/Storebox system and have this problem, here's a method for troubleshooting /dev/dsp can't be opened.

Video

X tries to start & fails

symptoms: you get the grey screen as if kdm were starting, but it eventually blinks out and drops you to the text login.keyboard and mouse are PS/2
solution: make sure the mouse is plugged in properly and in the correct port and reboot. X won't start if it doesn't think it has a mouse. --User:ideath 13:06, 12 May 2005 (PDT)

symptoms: you're returned to the console with the message "no screens found" and you're using certain kinds of ATI card (including the Riva128 card)
solution: Change the default color depth to 15, in /etc/X11/XF86Config-4 --User:Jeff

X won't start; video driver for onboard chip identified as "unknown"

Video problem with onboard video chip : VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics (rev 03).
solution: Change the driver to via in /etc/X11/XF86Config-4 Jeff 03:13, 6 Aug 2005 (PDT)
second solution: Change the driver to vesa in /etc/X11/XF86Config-4 if via doesn't work. Jeff 03:14, 6 Aug 2005 (PDT)

X overdrives monitor

symptoms: monitor presents high frequency scan lines and displays squished version of x
solution: check for IRQ conflict and set IRQ 3 only to legacy. Magix identified the chip but chose "unknown" driver. X wouldn't start. When we substituted "via" for "unknown" in the /etc/X11/XF86Config-4 file, x windows would start but the only resolution we could get was 600x480. A bunch of googling later we tried "vesa" for the driver and kdm worked fine. --Roy Marshall

symptoms: everything's fine until you try to go into X; then the monitor says FREQ OUT OF RANGE. it's the first time this previously-configured system has been used with this particular monitor.
solution: run magix to reconfigure X with the proper frequencies.

Login problems

Can't log in

symptoms: you try to log in with kdm, it pauses very briefly and drops back to grey screen/login.
solution: no clue. suggestions: go to the command line (ctrl-alt-f1) login as root, turn off kdm and run startx

freekbox~# /etc/init.d/kdm stop
freekbox~# startx

see what the error message is. If that doesn't work, try checking the logs in /var/log/X<tab>

I am assuming this is where the kdm login screen appears, but logging in does not go to the desktop, but back to the kdm login. I have had two situations where this happens. One was a box with all the hard drive space used up. The other was where I was trying to log into a window manager that was not actually installed. -- MW 09:39, 19 Aug 2005 (PDT)

Networking

Flaky ethernet card

symptom: the computer can't connect to the network after it's been imaged.
solution: Some ethernet cards will work to install the image, but not to connect from the OS. I generally end up swapping out the NIC and it will work fine. -- MW

Modems

moved to modem configuration

Extras